Can protocol commands not working

It’s been a while now that can protocol commands don’t work.
It puts out an error saying "object has no attribute ‘can’ " when I run the following command
(That problem doesn’t apply when I put the can command like here: odrv0.can.config.baud_rate

In the beginning I thought it was a firmware problem since at the time I hadn’t upgraded to the final one, but everything is perfectly upgraded and I still get that error.

Can you help me?

odrv0.axis0.config.can.node_id = 0

Yes @Wetmelon , I haven’t written the command wrong.

I’m sending you an image to see the problem crearly.

Are you running a very old firmware?
It might have been called axis0.config.can_node_id before they grouped the CAN configs together.

You can always use odrv0.axis0 on its own to list all of the properties of the axis. Tab completion is also available.

Oh, I read it incorrectly :slight_smile:

Since you’re on an older version, try config.can_node_id = 0. or update your firmware.

1 Like

Thank you! :grin:

This actually worked but it triggers my curiosity.
I don’t understand how can it work when i have everything updated to v.0.5.3

Are you sure you have updated the firmware? Maybe you updated the odrive pip package (i.e. odrivetool) but the odrive still runs the old firmware?
What does the odrive itself report its version as?