Can't calibrate motor with absolute AS5047P encoder


I am currently trying to set up my motor with an absolute encoder(odrive v3.6 56v) after changing the necessary settings I run the encoder offset calibration but nothing happens. when I dump the errors I get this:
axis: Error(s):
UNKNOWN ERROR: 0x00000040
motor: Error(s):
sensorless_estimator: no error
encoder: no error
controller: no error

does anyone know how I can fix this?

kind regards

Here is something you might try :slight_smile:

It looks like there is an issue with the driver of the motor (MOTOR_ERROR_DRV_FAULT) and the axis is in an invalid state (AXIS_ERROR_INVALID_STATE).

Here are a few things you can try:

  1. Check the motor and power supply connections to ensure they are properly connected.
  2. Try resetting the ODrive by powering it off and on again.
  3. Make sure that the motor is compatible with the ODrive controller and the voltage rating matches.
  4. Check the motor and encoder wiring to ensure they are correctly connected.
  5. Verify that you have set the correct motor parameters, such as the pole pair count, current limit, and velocity limits.
  6. Check that the firmware on the ODrive is up to date.

If none of these solutions work, it might be helpful to post your question on the ODrive forum or consult the ODrive documentation for further troubleshooting steps.

Hope this helps :slight_smile: ChatGTP.

Thanks for your answer! I have checked those parameters but unfortunately it still doesn’t work. Does anyone have any other ideas?
kind regards

Which firmware version are you running?
Could you please share your config, and post the output of <odrv>.get_drv_fault() after running the failed calibration?