Cheap Modular Encoders from CUI


#1

Hey guys super excited about this project. I just wanted to post here a source I’ve found for cheap $20-$30 encoders that are up to 12 bit resolution. I am currently using one for a direct drive force feedback steering wheel for a pc racing simulator.

digikey and mouse carry these
http://www.cui.com/catalog/components/encoders/incremental/modular

Hope this helps somebody.

-Chris


#2

I have one of these but haven’t tested it yet. I’ve heard from multiple people that they can be finicky and unreliable, but I’d like to see for myself.


#3

Those are the encoders I am using. They seem to be the industry standard for mid range CNC servos. I am using the HK 6374-149 motors so I had to make a mounting bracket to mount the motors. Then I put the bell prop adapter on my lathe and turned it down to 8mm and that is where I am mounting the encoders.


Getting started: power supply and resistor selection
Why is my odrive 3.2 not doing its initialisation sequence after a power off->on?
#4

Awesome! Looks badass! ;D


#5

@Bart any chance you are willing to share that CAD file so we can try a 3D print of it?


#6

Sure, no problem. I use BobCad for my cad tool and I have to convert it to STL or Step. Which do you prefer?


#7

bart,

I’m really curious about how you mount those damn CUI encoders. to be more precise, how you make the mecanical connection between the end of that turnigy aerodrive motor and the CUI encoder.

Can you post additional pictures of it? or did you model everything in CAD? (me, i prefer STEP format :p)

thanks


#8

@Bart Thanks! I would prefer STL but can work with STEP too.

-Brandon


#9

#10

hello,

I finally received my CUI 490-AMT102-V (purchased from https://www.mouser.com/ProductDetail/CUI/AMT102-V/?qs=sGAEpiMZZMvy8cVzszrmR8e0mUKZ7grDKaNMqTNrY3iTjPe3k%2bpUaQ==)

I’m struggling with the pinout. It can’t see it on the pictures.

I know the question feels a bit stupid but

=> Can anyone kindly help me with what pin on the CUI encoder should connect to what on the odrive board?

Thanks

(by the way, it’s the last step prior to sending a picture of my latest mount :D)


#11

Does the information in either of these posts help?
1. 2.


#12

yep< looks like it will do the trick. i’ll try and report.
and hopefully will come back with a nice picture… We’ll see :slight_smile:


#13

yep it did work i think. but i have another problem now :smiley: