DC_BUS_VOLTAGE_ERROR on odrive S1 with Hoverboard motor


Ok…so this is a bit embarrassing… turns out my battery had a problem after all…
I’d still be really thankfull if somebody could share their config for odrive S1 with a hoverboard motor!

I’m new to the odrive and I’m trying to configure a hoverboard motor with my odrive S1.
I’m using a the original Hoverboard battery as a power source (10s2p 36V).

I confugured everything in the GUI using some values from the Hoverboard guide in the old documentation.

But when I try to run the calibration sequence I keep getting the DC_BUS_UNDER_VOLTAGE after not even a second.
My battery is charged and I don’t see a voltage drop looking at the power rails while trying to run the callibration.

Any idea which setting might be the problem? Or is anybody succesfully using a hoverboard motor with the S1 and would share their settings?

“fw_version”: “0.6.6”,
“commit_hash”: 307587176,
“product”: “5.2.0”,
“active_errors”: 0,
“active_errors_str”: “NONE”,
“disarm_reason”: 512,
“disarm_reason_str”: “DC_BUS_UNDER_VOLTAGE”,
“procedure_result”: 3,
“procedure_result_str”: “DISARMED”,
“last_drv_fault”: 0,
“internal_issues”: 0

this is my config ( i think? ) - i already played with the odrv.axis0.config.motor.calibration_current value without success.

odrv = odrv0
odrv.config.dc_bus_overvoltage_trip_level = 42.5
odrv.config.dc_bus_undervoltage_trip_level = 30
odrv.config.dc_max_positive_current = 22
odrv.axis0.config.motor.motor_type = MotorType.HIGH_CURRENT
odrv.axis0.config.motor.torque_constant = 0.516875
odrv.axis0.config.motor.pole_pairs = 15
odrv.axis0.config.motor.current_soft_max = 25
odrv.axis0.config.motor.current_hard_max = 45
odrv.axis0.config.motor.calibration_current = 25
odrv.axis0.config.motor.resistance_calib_max_voltage = 4
odrv.axis0.controller.config.input_mode = InputMode.PASSTHROUGH
odrv.axis0.controller.config.control_mode = ControlMode.VELOCITY_CONTROL
odrv.axis0.config.torque_soft_min = -2.584375
odrv.axis0.config.torque_soft_max = 2.584375
odrv.axis0.config.encoder_bandwidth = 100
odrv.hall_encoder0.config.enabled = True
odrv.axis0.config.load_encoder = EncoderId.HALL_ENCODER0
odrv.axis0.config.commutation_encoder = EncoderId.HALL_ENCODER0

We’ll have an updated hoverboard guide soon, in the mean time all the necessary configurations should already be baked into the GUI Wizard.

Selecting BotWheel (you can customize the values if need be) and Hall Encoder will give you the correct config to pass calibration, from there you can move on to tuning the controller.

If this is not the case (once the battery situation is fixed) please let me know the failure mode, and post any config changes you made to the BotWheel+Hall Encoder config that the Wizard generated.

1 Like