Disable inertia compensation

I am implementing joystick control of robot - and then I release joystick - robot should just stop asap, but not move back to point there it was at the moment then I sent cmd “vel_setpoint 0”. I use CONTROL_MODE_VELOCITY_CONTROL and 0.4.12 firmware. How can I achive such behaviour?

This behavior is caused by the velocity integrator gain. You can change this by setting odrv0.axis0.controller.config.vel_integrator_gain to 0 and bumping up odrv0.axis0.controller.vel_gain a bit to compensate for the lack of integrator gain.

1 Like