Endstop offset doesn't affect 0 position

Hello! We are using the ODrive S1, D5065 270KV and the CUI AMT10E2-V. We’re trying to configure a homing sequence. We want the 0 position of the motor to be 2 rotations away from the endstop. However, when the AxisState Homing is run, the motor will always return to its initial position, with the 0 position being there as well.

For simplicity all settings are left on default, as configured by the UI.
Settings we’ve configured ourselves:
odrv.axis0.controller.config.homing_speed = -2
odrv.axis0.controller.config.vel_ramp_rate = 0.2
odrv.axis0.trap_traj.config.vel_limit = 2
odrv.axis0.trap_traj.config.accel_limit = 1
odrv.axis0.trap_traj.config.decel_limit = 1

odrv.config.gpio2_mode = GpioMode.DIGITAL
odrv.axis0.min_endstop.config.gpio_num = 2
odrv.axis0.min_endstop.config.enabled = True
odrv.axis0.min_endstop.config.offset = -2
odrv.axis0.min_endstop.config.debounce_ms = 50.0
odrv.axis0.min_endstop.config.is_active_high = False
odrv.config.gpio2_mode = GpioMode.DIGITAL_PULL_UP

We’ve confirmed that the endstop state works as normal, and the motor does complete the homing sequence without any errors. However, it seems that the odrv.axis0.min_endstop.config.offset setting does nothing. Did we overlook something, or am I misunderstanding a setting?