Exception in thread Thread-1:


I’ve been trying to get the Odrivetool to work for several hours now, but so far to no avail. When I start it from anaconda I get below error, after which the help command works, but when I type odrv0. there’s no response.

ODrive control utility v0.4.2
Please connect your ODrive.
You can also type help() or quit().

Exception in thread Thread-1:
Traceback (most recent call last):
File “C:\ProgramData\Anaconda3\lib\threading.py”, line 916, in _bootstrap_inner
File “C:\ProgramData\Anaconda3\lib\threading.py”, line 864, in run
self._target(*self._args, **self._kwargs)
File “C:\ProgramData\Anaconda3\lib\site-packages\fibre\usbbulk_transport.py”, line 190, in discover_channels
devices = usb.core.find(find_all=True, custom_match=device_matcher)
File “C:\ProgramData\Anaconda3\lib\site-packages\usb\core.py”, line 1263, in find
raise NoBackendError(‘No backend available’)
usb.core.NoBackendError: No backend available

In [1]:

If I try a complete odrive command like “odrv0.vbus_voltage” I get the following:

In [3]: odrv0.vbus_voltage

NameError Traceback (most recent call last)
C:\ProgramData\Anaconda3\lib\site-packages\fibre\shell.py in ()
----> 1 odrv0.vbus_voltage

NameError: name ‘odrv0’ is not defined

In [4]:

Any help is greatly appreciated!

Did you install libusb-win32 with Zadig?

Hi, thanks for your response.

I did install libusb-win32 with Zadig, and I did it again after your comment just to make sure I didn’t mess it up, but I still get the same error?

I tried removing everything I had installed and start from the beginning again, still the same error. Is there something I can do to generate some more useful output to pin down where this is going wrong?

The issue is that libusb isn’t installed properly, hence the usb.core.NoBackendError: No backend available


Could you give me a hint as to what libusb version I need? I tried uninstalling/re-installing using pip, to no avail. Somewhere I came across a notion that libusb-win32 is required? pip can’t find a version of it, and I tried googling and found this: https://sourceforge.net/p/libusb-win32/wiki/Home/. However, running the installer for that libusb-win32 installation package just flashes a window real quick without seemingly doing anything, it seems like it just won’t install.

Thank you!

Got frustrated with other issues I was having as well and did a fresh install of windows 10 on my PC. Then followed installation instructions again, now it works!

There must have been some conflicts with previously installed drivers or something like that, this is now resolved. Thank you for your help.

1 Like

I’m having this same issue and don’t want to reinstall my entire operating system. Is there any other way?

OK, sorry for the snarky comment.

I read through the instructions a second time and found out how to actually update the ODrive driver using Zadig.

Use the Zadig utility to set ODrive driver to libusb-win32.
Check ‘List All Devices’ from the options menu, and select ‘ODrive 3.x Native Interface (Interface 2)’. With that selected in the device list choose ‘libusb-win32’ from the target driver list and then press the large ‘install driver’ button.

All is well. Now to actual testing!