Homing / Endstops

Hi
i can’t get the Homing function to work.

Firmware:
fw-v0.5.2

Settings:
odrv0.axis0.min_endstop: config: gpio_num = 6 enabled = False offset = 2.0 is_active_high = False pullup = False debounce_ms = 50
I used a standard 3d-Printer mechanical Endstop with 3 wires. (Red goes 3v/5v, black at ground and green to GPIO 6)

The Endstop will show activity by Blinking and with odrivetool and odrive-gui i can see that it will properly recognized.

But the homing procedure will not stop then the Endstop was triggered!
If i trigger it multiple times or longer by hand will only result in a “AXIS_ERROR_MIN_ENDSTOP_PRESSED”

I try different settings but no luck.

  • setup other GPIO Pins
  • switching “is_active_high” or “pullup”
  • use other axis
  • change the endstops

plz help me
Kim

1 Like

Thanks for the feedback, we will investigate this.