Hoverboard Motors not working

Hello all. I am using a 48V odrive with 2 hoverboard motors and a 36V battery (taken from a swagtron t1). I am using the included braking resistor, and have updated the odrive to the latest non-dev firmware. When I ran the motors with closed loop control, both motors spun for about 2 seconds, and then axis 0 stopped spinning. My battery is fully charged and I am receiving 38V. To try and solve the problem, I wiped the configuration and tried to re-config motor 0. It is now not even calibrating the motor (no beep), or the encoders (the motor don’t spin). I am getting no encoder error, and I am getting a 0x01 error in the motor config. Axis 1 works fine. What should I do?

Try seting motor.config.resistance_calib_max_voltage = 4

I just tested again after letting the odrive sit… now axis one is having the issue where it stops turning after a while & won’t calibrate. I tried doing the resistance calibration but it still won’t work. The error is 0x001. I was looking at the docs, do I need 22nf capacitors? Encoder error ERROR_ILLEGAL_HALL_STATE

I think you may need the capacitors.

I will try that… thank you

Can I solder the resistors to the hall effect wires or do I need to solder them to the underside of the Odrive?

Anywhere that’s within 10cm of the ODrive board should be OK.

Ok. I needed to finish the product by today, so I had to get the capacitors soldered to the underside by a professional since my equipment was substandard to say the least. However, I am pleased to say that the capacitors fixed the problem! You should consider putting the whole capacitor situation in the M0 for the hoverboard motor setup, as it would probably save many people the hassle that I went through. Anyways, thank you so much for your help, and I look forward to using Odrive again in the future.

2 Likes