Motor quickly stops spinning

i am using an odrive V3.6 56V and a eaglepower 8308 BLDC 90KV motor. When I try to spin the motor one revolution (after it did the calibrating and it is stationary) the motor spins a little bit, but then stops without finishing the revolution. When I look for the error this is what I get:" In [34]: dump_errors(odrv0)

system: not found


axis: Error(s):

UNKNOWN ERROR: 0x00000200

motor: Error(s):


sensorless_estimator: no error

encoder: no error

controller: Error(s):



axis: no error

motor: no error

sensorless_estimator: no error

encoder: no error

controller: no error
does anybody know what I can do to make my motor work properly?

This is just an overspeed error. You just need to set motor.config.vel_limit a bit higher.

The ‘deadline missed’ error is misleading, it’s caused by the overspeed error.
The unknown error is probably because you use either an old odrivetool or an old firmware, and they are not fully compatible. But again, it’s probably being caused by the overspeed.

1 Like

thanks for the answer, do you mean controller.config.vel_limit, because I don’t find motor.config.vel_limit anywhere

1 Like

Yes, sorry, controller.config is right

1 Like

thanx, that worked for me! and what can I do when I want to make the motor spin slowly?

Try the trajectory control?

that worked as wel! thank you for the help

1 Like