None of my ODRIVES will connect

Hello, please help. I have 6 odrives running the v3.6-24V firmware. I flashed them all with DfuSe Demo and the flashing seemed to go well. I’m working off of a windows and no matter what they will not connect to my computer when not in DFU mode. in DFU mode they connect fine, they don’t flash with odrivetooldfu but they flash with the DfuSe demo. I doubt its the odrives because i have SIX and there’s no way all of them are broken. Windows doesnt even give an indication anything is plugged in and it doesn’t even come up in Zadig. Please helpppp

Okay so turns out to fix this, you need to first put the odrives in DFU mode, select that in ZADIG and change the driver and then put it in run and then use zadig again to set the driver and then everything connects

Just kidding, that only worked for One odrive it seems

@madcowswe may have a better answer than I do for this. Did they work before you flashed them, straight out of the box?

I honestly didnt try - I just flashed it with the latest firmware form odrivetool dfu when I got them

Side note: The real reason I want to connect to odrivetool is to set the parameters of the system like startup closed loop control and etc. I was also thinking, I can set these in source on github, recompile my own version of the firmware, and upload it using an STLink right? Would this be a valid option for setting parameters on more than one odrive quickly? Is there anything I should watch out for?

I had the same problem, did you use a current limiter on your power supply? In my case, the board started not well with a too small current limit.

So I tried it off the following supply:

Then I thought power was the issue and tried it off of a LiPO battery directly? Any rules with Odrives and LIPOS?

So you bricked your device before you tested it? :wink:

Yes. Also if you flash the master firmware with no changes via STLink, we can be much more confident that the flashing procedure worked correctly (DFU is a bit unreliable it seems).

It’s an option. You can also download the config file in a JSON format from one ODrive then config the others to match via Python.

So you bricked your device before you tested it? :wink:

Yes you’re right, I might have - oops LOL . I think I’ll take your advice and flash the original 3.6-24V firmware first and try to get that to connect to my Mac. Thank you for the python suggestion - I didn’t think of that one !