ODrive board 3.6 not showing up as com port [SOLVED]

I had the ODrive 3.6 board working fine on one computer in Windows 10.

Then I started setting up a new computer, installed Anaconda, installed odrivetool using pip, etc.

but the Board does NOT show up as a Com port in windows.

I can connect to the board from odrivetool… and I can run python scripts (for homing for instance)

I used the ZADIG tool to update the drive according to instructions on getting started but still no COM port. I am using ASCII protocol to control my motor from another program and I need to be able to specify the port!

Please help why was this working on one computer but not on this one???

here is a screen shot from device manager after using the zadig tool

Looks like it’s running in Native interface mode. See Native Interface and CDC interface. It may show up as a COM port if you flash that software but I thought it only showed up as a CDC interface?

1 Like

Solved: I found that if I select the CDC interface and then use Zadig software to update the driver to “USB Serial (CDC)” then it would show up as a proper windows COM port.

But I have had no success trying to flash the firmware in windows using odrivetool dfu or DfuSe app. I tried uninstalling and deleting the driver, and every combination of driver available on both interfaces. The DfuSe just never lists it as a device no matter what I try.

Fortunately I have a Ubuntu Linux installed on a laptop and that works just fine to flash the firmware with odrivetool dfu.

1 Like

Hi,the screen shot of my device manager looks like @tomsepe 's. I want to make a upper machine application to commucate with odrive, now I have two questions:
1.I have written “CONFIG_USB_PROTOCOL=native” in tup.config file, so the odrive runs in native interface mode, if I change those codes to “CONFIG_USB_PROTOCOL=ascii” and flash again, it will run in ascii interface. Do I understand correctly?
2. In the file “ODrive-master\Firmware\Board\v3\Middlewares\ST\STM32_USB_Device_Library\Class”, there is only USB CDC, so I have to make odrive run in ascii interface mode and treat odrive as CDC to communicate?
I’m Looking forward to your reply,Thank you!