Odrive grinding to halt after a couple of seconds, giving current limit error

We have a four wheeled robot with one odrive motor per side connected to an odrive control card. troubleshooting atm, and the robot is lifted up from the ground so that wheels are rolling free, very low resistance just the internal from gearbox and bearings. when running the motors at about 15 turns per second, the motors eventually slows down and grinds to a halt. alternatively, the current sent by the card increases until the maximum current is reached and an error is thrown for that side.

We further tried using motors that are outside the robot shows no error, indicating that internal friction and drivetrain stuff is too heavy for the motors even if it is lifted above the ground. When we applied load to these free spinning motors they showed the same behaviour.

what kind of troubleshooting can i do to further isolate the problem? what type of solutions are available? the robot needs to carry about 90 kg of load and the robot itself weighs in at around 30 kg - are two odrive motors not enough? 150 kv version. It hs managed to do so previously, can the motors be worned out?

Dumping errors in odrivetool shell yields:

In [137]: dump_errors(odrv0, True)
axis: Error(s):
motor: Error(s):
fet_thermistor: no error
motor_thermistor: no error
encoder: no error
controller: no error
axis: no error
motor: no error
fet_thermistor: no error
motor_thermistor: no error
encoder: no error
controller: no error


Encoder problem. Noise, slippage, or you have gearing between the motor and encoder that’s not quite a whole number.

Exact same issue for me. First was getting current limit violation but then I increased the limit to 100 and started getting the current saturation error instead.

Couldn’t be an encoder problem for me since I’m using a hall effect encoder which is built into the motor, and the same motor with exact same configuration works on other Odrive boards (and even on the other axis on the same board). Only one axis on the board seems to have the problem. Brand new board so I don’t think it would be physical or electrical damage.

Are there any other possibilities or ways to troubleshoot?

That sounds very similar to my problem - have you tried plotting the current like I tried in this topic Errorbehaviour on Motorcurrent in velocity control ?
It seems like lots of people are having this problem.