Odrive is not recognized when connected to PC

Even if Odrive is connected to the PC via USB, it is not recognized.
Do I need a special USB cable?

Hi! Can you please provide more details - which ODrive is this? Is the PC running Windows, Linux, or Mac OS? Are you trying to connect via the GUI or ODrivetool

1 Like

Thanks for your massage.
The version of ODRIVE is V3.6.
I am using ubuntu on windows. I am connected to odrive with USB.

When I run odrivetool, it says “Connected to unknown device”.

coco@coco-virtual-machine:~$ odrivetool
ODrive control utility v0.6.5.post2
15:44:34.190192700 [USB] Could not claim interface on USB device: -6
Website: https://odriverobotics.com/
Docs: https://docs.odriverobotics.com/
Forums: https://discourse.odriverobotics.com/
Discord: ODrive
Github: GitHub - odriverobotics/ODrive: High performance motor control

Please connect your ODrive.
You can also type help() or quit().

Connected to unknown device 20843794304E (firmware v0.5.6) as odrv0

Also, when saving the configuration, the connection will be interrupted once. Then it will come back again.

No need for a special cable, it looks like you’re connecting fine but odrivetool is not able to identify the hardware version. Can you confirm running odrv0.vbus_voltage works?

For regular use this shouldn’t be an issue, but if you ever need to run odrivetool dfu you will have to download and point to the correct elf file.

Do you see Could not claim interface on USB device: -6 every time you open odrivetool? Or did you have another instance running whe you captured this output?

All good here, save_configuration() reboots the device so this is normal/expected behavior

1 Like

Thanks Nicholas.
thanks to you i solved it!

1 Like