ODrive not found/disappearing

Morning! I am getting some weird issues with my ODrive 3.5-24V powered with 12V connected to a 12V motor and a 4000cpr encoder (AS5047). It keeps disconnecting from USB during operation, and can then no longer be detected by the host computer. The only way to reset it was to reflash the firmware using the ST-Link, but now that is also not working.
Things I’ve tried:

  • power cycle everything
  • triple-check connections
  • DFU firmware update
  • ST-link update

Running odrivetool gives this:

:~$ odrivetool
ODrive control utility v0.5.1.post0
Website: 'link'
Docs: 'link'
Forums: 'link'
Discord: 'link'
Github: 'link'

Please connect your ODrive.
You can also type help() or quit().

In [1]: 

Reflashing with the ST-link gives this:

:~$ openocd -f interface/stlink-v2-1.cfg -f target/stm32f4x.cfg -c init -c "reset halt" -c "flash write_image erase ODriveFirmware_v3.5-24V.elf" -c "reset run" -c exit
Open On-Chip Debugger 0.10.0
Licensed under GNU GPL v2
For bug reports, read
Info : auto-selecting first available session transport "hla_swd". To override use 'transport select <transport>'.
Info : The selected transport took over low-level target control. The results might differ compared to plain JTAG/SWD
adapter speed: 2000 kHz
adapter_nsrst_delay: 100
none separate
Info : Unable to match requested speed 2000 kHz, using 1800 kHz
Info : Unable to match requested speed 2000 kHz, using 1800 kHz
Info : clock speed 1800 kHz
Error: open failed
in procedure 'init' 
in procedure 'ocd_bouncer'

Reflashing through DFU gives this (after switching the DFU switch):

$ sudo dfu-util -a 0 -s 0x08000000 -D fw.bin
dfu-util 0.9

Copyright 2005-2009 Weston Schmidt, Harald Welte and OpenMoko Inc.
Copyright 2010-2016 Tormod Volden and Stefan Schmidt
This program is Free Software and has ABSOLUTELY NO WARRANTY
Please report bugs to  'link'

dfu-util: Invalid DFU suffix signature
dfu-util: A valid DFU suffix will be required in a future dfu-util release!!!
dfu-util: No DFU capable USB device available

(I had to remove links because new users can’t share more than 2 links per post)

Is the board toast? Is there a better way to reset the board?

Thanks in advance!

Update: trying the same with a different ODrive, same issue. The board is not being detected.

Have you tried adding Ferrite cores around the motor phase wires to supress Electromagnetic Interference? I too had the issue of USB disconnections. The Ferrite cores worked well for me and not faced this problem ever since.

1 Like