Odrive Pro successfully connecting to computer but will not connect to the web gui

Hello! I’ve been using ODrive pros for a project that I am working on successfully for a few weeks but as I started working on it today it seems something has gone wrong with my ODrive. It can fully connect with odrive tool in powershell on my windows laptop but will not connect to the web gui.

Things I’ve tried:

  • Power cycling
  • Trying different cable and different usb isolator
  • DFU for the ODrive pro
  • Plugging in another ODrive pro (No problems with a different one)

None of these solutions worked and i’m a bit lost on what to try to do going forwards. It doesn’t seem to be a firmware issue on the ODrive or an issue with drivers.

Let me know if you need any more information or have any ideas with things to try. Thanks!

Hi there! What web browser are you using? Currently the GUI is only compatible with Chrome and Edge.

1 Like

Thanks for the reply, thankfully I did figure it out though. Apparently even though the wiki says that you can either use Win USB or libusb-win32 drivers from Zadig, It looks like the Web GUI is only able to find the ODrives if you are using the Win USB drivers, at least on my computer.

Not sure exactly what is causing this, I’m using chrome as my browser and like I said before I am able to find and connect to the ODrive with odrivetool in powershell. If anyone at ODrive needs more info about my computer/setup to try and fix this I’d be happy to post more info, just let me know :slight_smile:

1 Like

Hey Zach,

Super weird issue, that’s really good to know, thank you! Is using WinUSB okay for now, or does it still not work?

1 Like

With Win USB everything has been working great for now, If I figure out anything else about what’s causing this I’ll be sure to post it here though.

1 Like

Great, thank you! Likely just something with USB descriptors, I’ll forward it to the team and get the docs updated.

1 Like

Edit: Fixed. Uninstalled both Native and CDC drivers from windows device manager. Make sure to force driver/file removal. Removing in for one drives instance did not fix it for all drives, I had to uninstall/remove for all drives. Now they connect and load with the original drivers that work with the web gui (Win32…?)

FYI, exact same issue for me. Had all 4 of my Pro drives unable to connect to the web gui.

I replaced the Native Interface driver with WinUSB and it works for one connection cycle, then the driver is automaticly replaced with libusb0 again. This happens for all drives… Any thoughts on forcing the original OEM driver (WinUSB?)