Odrive S1 motor calibration error

Hi community,

I am using an Odrive S1 with onboard encoder and an EaglePower 8308 motor (20 pole pairs/ 40 magnets, 22A max continuous current). I implemented odrivetool commands up to calibrating the motor. When I run motor calibration, the motor rotates in one direction and stops and calibration error pops up. I also did the process with the WebGUI and it suggested that the motor pole pair value is wrong.

Kindly suggest a troubleshooting process.


Hi there - usually this is caused by a misalignment between the encoder magnet and the ODrive S1’s sensor, or load on the motor during calibration.

When I rotated the motor by exact one turn the motor position in the gui also showed increase or decrease by one turn. Based on this I thought maybe that might not be the issue.

Additionally, I changed the encoder to a CUI AMT 102 encoder and tried using the S1 with a D6374 motor which I definitely know works. The calibration still paused at the exact same place and resulted in an error NO_Response.

Further, when I tried calibrated my 20 pole pair motor or the D6374 with CUI AMT 102 encoder using an old Odrive 3.6 it just worked very easily.

Hence I doubt whether the S1 is working normally.

Can you share your configuration in the GUI? Screenshots of the configuration pages are fine.