Odrivetool no serial number

I was running one of my projects four wheel device (2 odrives 3.6-56v) when one of the odrives quit.
Parked the device and and tried odrive shell since I was using ssh. One odrive hooked up but the other did not see serial number. removed odrive from motors and tried odrivetool on my pc using a 20 volt battery.

Question …should I be able to connect to odrive serial number without a motor installed using odrivetool?

If I should be able to see a serial number and I do not what are my options?

1 Like

Going forward with this I can not find any listing for Odrive or STM using
lsusb in ubuntu 20.04 linux…

I have a ST-Link V2 but haven’t found a link to the documentation on how to hook it to the Odrive board.

Any pointers would be appreciated!


1 Like

So this morning I went and checked my Odrive that failed yesterday…
it was rejuvenated…
did a little more digging on this forum and found out that USB is fine for configuring and calibration, but is not the communication of choice …it looks like CAN BUS is…

my controller is a Jetson Nano and it does not have CAN capabilities but a CAN bus hat is available. I have ordered one and while I wait I will endeavor to learn CAN BUS.

1 Like