Pip3 install matplotlib error Jetson TX2 Ubuntu 18.04

When attempting to install the odrive using pip3 install I get this error:

The code always seems to freeze on:

Downloading https://files.pythonhosted.org/packages/be/74/24d058c17b155d131359f1cd01e120b3954686bf8b7853172b279237e1dc/matplotlib-3.1.3.tar.gz (40.9MB)
99% |████████████████████████████████| 40.9MB 26.0MB/s eta 0:00:01

and results in this error:

Command "python setup.py egg_info" failed with error code 1 in /tmp/pip-build-0gw9bigc/matplotlib/

I tried downloading monotonic, installing python-matplotlib seperately with no success… Any ideas?

Hello, I got a Jetson Nano too and I’ve got almost the same error

I precise that I installed python &python3 & pip & pip3, tried with both and no success.

it result in this error :
Command “python setup.py egg_info” failed with error code 1 in /tmp/pip-build-o5ayL3/odrive/

Is someone could help us ?


ok it needs monotonic and it works

ok it works well with pip but trouble with pip3

I prefer py -2 -m pip install <pkg> or py -3 -m pip install <pkg> instead of the pip2 / pip3. Seems to be more reliable.

You can also directly call out the python version. C:/Tools/Python37/python.exe -m pip install odrive

Hi, I am having the same problem on a Jetson Nano. I already went through the same steps and installed monotonic and matplotlib manually. Still got the “python setup.py egg_info” failed with error code 1 in …


I think it has something to do with:

ERROR: Failed to build one or more wheels.

Also, when starting

sudo pip3 install odrive

When starting the procedure, it tells me the directories /home/beluga/.cache/pip/http and /home/beluga/.cache/pip is not owned by the current user. If executing pip with sudo, you may want sudo´s -H flag.

Please help me solve this problem.

Hello @Beluga ,

I had the same issue. Solved and it turns out that is because the system has an out of date version of setuptools.

just have a try and good luck

pip install --upgrade setuptools
1 Like

Wow, thank you very much for the quick answer. It helped installing odrivetools with pip (pip3 did not work). I hope everything will be working now, thank you again.


I use a Jetson Xavier NX and unfortunately have the same problem.
Unfortunately, none of the solutions work.

Hopefully someone else has a suggestion.

Solved it by installing mathplotlib manually

sudo apt-get install python-matplotlib


None of these helped for my trying to install on my Jetson Nano. I installed matplotlib, monotonic, setuptools.

What finally helped was suggestions in this thread: pip - Command “python setup.py egg_info” failed with error code 1 in /tmp/…/ - Stack Overflow.

Which is, I ran

pip3 install -U pip
pip3 install -U setuptools

And then ran pip3 install odrive. I hope this helps someone.

1 Like