Position control setup issues

Greetings everyone,

So I have had some success with setting up my ODrive 3.8 with a hoverboard hub motor. Going through the ‘getting started’ section, I get all the way through odrv0.axis0.requested_state = AXIS_STATE_FULL_CALIBRATION_SEQUENCE, which executes just fine and the numbers look good, but once I attempt to run odrv0.axis0.controller.pos_setpoint = 10000, it does not work. I even tried 10, 100 and 1000 for a setpoint. To no avail. With that being said, I can get it to turn and stop through the
odrv0.axis0.controller.vel_setpoint command just fine.

I have already incorporated the capacitors for the hall sensors and even got a RC transmitter to properly send signals (confirmed via vel_setpoint) but cannot get the motor to turn through pos_setpoint. I ran the dump_errors(odrv0) with nothing to report on. Green across the board.

Any help would be appreciated! I’m sure I’m overlooking something

So, if someone else has this problem, DOUBLE CHECK THE MODE YOU RUN IN! I followed the typical ODrive setup which calls to use Velocity and the hoverboard setup uses Position. Once I switched over to the Position mode, it worked!