Problem updating script


I have run into a problem with the script. I wrote a few lines of code there to update a function but when I tried using it the function works the same as it did before I made my changes. I looked into it a bit further and when I look through the error the code gives it seems to use the old code even though I saved the file. I tried again with a different computer and the error persisted. The change I wrote looks like this:

def oscilloscope_dump(odrv, num_vals, filename='oscilloscope.csv'):
    with open(filename, 'w') as f:
        for x in range(num_vals):

But in the error manager I get this: (the old code)

File ~/.local/lib/python3.8/site-packages/odrive/, in oscilloscope_dump(odrv, num_vals, filename)
    256 with open(filename, 'w') as f:
    257     for x in range(num_vals):
--> 258         f.write(str(odrv.oscilloscope.get_val(x)))
    259         f.write('\n')

I don’t really know if this is just an issue on my end but any help would be appreciated.

Make sure you do a pip uninstall odrive (and maybe delete any leftover Python/Scripts/ files) when working with / launching odrive from the git repo