Problem with tup when compiling ODrive source

Hello, I’m trying to compile the ODrive source on my windows PC using VSCode as IDE. I followed the guide on setting up the project and I think I have everything configured as supposed. When I run make tup initializes successfully but then throws a bunch of errors. I can compile the files manually without any issue.

Any idea what I’m missing or doing wrong?

*** Command ID=373 failed: arm-none-eabi-gcc -std=c99 -c Board/v3/Drivers/STM32F4xx_HAL_Driver/Src/stm32f4xx_hal_pwr.c -DHW_VERSION_MAJOR=3 -DHW_VERSION_MINOR=6 -DHW_VERSION_VOLTAGE=24 -DUSB_PROTOCOL_NATIVE -DUART_PROTOCOL_ASCII -D__weak=“ attribute ((weak))” -D__packed=“ attribute (( packed ))” -DUSE_HAL_DRIVER -DSTM32F405xx -mthumb -mcpu=cortex-m4 -mfpu=fpv4-sp-d16 -mfloat-abi=hard -Wall -Wdouble-promotion -Wfloat-conversion -fdata-sections -ffunction-sections -O2 -ffast-math -fno-finite-math-only -IBoard/v3/Middlewares/Third_Party/FreeRTOS/Source/portable/GCC/ARM_CM4F -IBoard/v3/Middlewares/Third_Party/FreeRTOS/Source/include -IBoard/v3/Middlewares/Third_Party/FreeRTOS/Source/CMSIS_RTOS -IBoard/v3/Middlewares/ST/STM32_USB_Device_Library/Core/Inc -IBoard/v3/Middlewares/ST/STM32_USB_Device_Library/Class/CDC/Inc -IBoard/v3/Drivers/STM32F4xx_HAL_Driver/Inc -IBoard/v3/Drivers/STM32F4xx_HAL_Driver/Inc/Legacy -IBoard/v3/Drivers/CMSIS/Device/ST/STM32F4xx/Include -IBoard/v3/Drivers/CMSIS/Include -IBoard/v3/Inc -I. -IDrivers/DRV8301 -o build/obj/Board_v3_Drivers_STM32F4xx_HAL_Driver_Src_stm32f4xx_hal_pwr.c.o
tup error: failed to create child process: No such file or directory

It’s not a great error, but it’s saying arm-none-eabi-gcc is not a file or directory. Make sure arm-none-eabi-gcc is on your path. You can check by opening a terminal in VSCode and typing arm-none-eabi-gcc --version

Thanks, that solved it!

Now I’m running into the next issue:

    1. python …/tools/odrive/ --output build/version.h
      *** tup messages ***
      *** Command ID=501 failed with return value -1073741701

I’m not sure if it is related but my board version is configured as CONFIG_BOARD_VERSION=v3.6-24V

Is python on your path? If you type python --version do you get Python 3.x.x?