Resistance error

I am encountering errors when trying to calibrate the oDrive with my motor. I am using the Nanotec BLDC 59 motor: DB59C048035-A - Brushless DC motor | NANOTEC.

I left the current_lim as 10 A, vel_lim as 5 turn/s, calibration_current as default, brake_resistance as 5 ohm (using a 5 ohm power resistor), the pole_pairs as 3, the torque_constant as .1 Nm/A, and motor_type as high_current.

When I tried the calibration, nothing happened and got these errors:
and the resistance being detected was 0.

Any ideas for how to fix this error?

  • Thanks

Did you try the instructions here ODrive.Motor.Error | ODrive ? Also, what bus voltage are you using?

try increasing motor.config.resistance_calib_max_voltage ?
Default is 2V, which with a 0.5Ohm winding will only push 4A through the motor, which is not easily measured by the ODrive’s current sensors.
increase it to 5V should give you enough headroom to avoid the error.

Thanks for the advice. I was able to get that error to go away, but I am running into a new error. I am getting the AXIS_ERROR_DC_BUS_UNDER_VOLTAGE. I tried increasing my DC voltage from 15 V to 30 V, but this did not seem to change anything. I tried reducing my vel_limit to 2 turns/s and my current_lim to 10 A, but this did not fix the error. Any other ideas?

Edit: Also, still detecting an inductance and resistance of 0 when I do odrv0.axis0.motor.config.phase_resistance, but maybe that’s just because it won’t calibrate.


Yes, I tried, but no success. Bus voltage was 15 V, but increased to 30 V.