STM32 BOOTLOADER instead of Odrive 3.x

Hello everyone,

When trying to download the right driver to the Odrive in Zadig, I cannot find the Odrive 3.x.

On the website is stated:

Check ‘List all devices’ from the options menu, and select 'Odrive 3.x Native Interface (Interface 2).

When I check ‘List all devices’ I can only see STM32 BOOTLOADER, I am able to install a driver to this succesfully. But when I type odrivetool in the cmd prompt it states:

ODrive control utility v0.5.1.post0

Please connect your ODrive.
You can also type help() or quit().

I have allready done the pip install a few times and this is allways succesfull. Can anybody share their thought about this? Is the STM32 BOOTLOADER the same as the Odrive3.x?

Never mind it works now, I had to unplug the power supply for longer then I had allready tried. :sweat_smile:

The board is not showing up anymore, not even STM32 BOOTLOADER. Any advice on this?

Please check that your DFU / RUN switch is in the “RUN” position. If it doesn’t show up, put it in the “DFU” position and see if it comes through as STM32 BOOTLOADER again, then attempt to re-flash.

Thanks for the advice, I managed to solve the problem by reflashing on macOS. On windows it didn’t work for some reason.