The motor error of "ERROR_DRV_FAULT"

Hello,
About the board of odrive 3.4-48V
When the power is plugged in,display “ERROR_DRV_FAULT”.reading the drv_error value gives 1024.
image
However,when I remove the motor from the board, the result of “dump_errors(odrv0)” is normal.Is this something that can be fixed in the settings, or should I be looking at replacing the gate driver?
Another problem is that it takes 20 to 30 seconds to connect to the computer by using odrivetool.

Hmm, it’s odd that’s it’s on both axes. Can you do dump_errors(odrv0, True) and then dump_errors(odrv0) again? This will clear the errors with the first call, then you’ll see the “new errors”. I would also double check that the firmware is up to date (pip install odrive --upgrade)

After entering the command, there is nothing changed .What else can I do,thanks.

dump_errors(odrv0, True) will still print the existing errors, and THEN reset them. So you have to dump_errors one more time to see any new ones.

it‘s same.

Hello
I used the vscode ,found the error of DRV8301_FaultType_GVDD_OV
image
How did this mistake come about, what can I do ?

1 Like

What is your power supply voltage? Any chance it has ever been higher than 60V? (e.g. using the ODrive on a 56V supply without a brake resistor)

Try measuring the voltage of GVDD (voltage across C32, C47 or C61) - if it’s higher than 16V then something is very wrong with one of the gate drivers.

If there has been a short from DCBUS to GVDD, for example, then it might have blown up all three gate drivers. But if you’re lucky then they have protected themselves.

My power supply voltage is 12V, the voltage of GVDD is 11V. however, I only checked the short from DCBUS to GND, there is no short.

Are you using a brake resistor?
If not, there’s a small chance your motor could have generated over 60V at some point.
What were you doing just before it failed?

When I put the motor on the board,the error happened.

when the board odrive without motor, everthing is ok.

The error happens as soon as you connect the motor? Or does it happen when you try to change axis.requested_state?

when I didn‘t connect the motor,I run dump_errors(odrv0),display no error. Then I connect the motor, and power on, connect again, run dump_errors(odrv0), display the error.

I don’t know why, for the above problem, after I run the dump_errors(odrv0, True) and contact the IO port “EN_GATE” with the ground for a period of time, no error will be displayed.
But when I run “odrv0.axis0.requested_state = AXIS_STATE_MOTOR_CALIBRATION”, displayed ERROR_PHASE_RESISTANCE_OUT_OF_RANGE, I’m sure motor leads are connected securely. And I found that the IO ports GH_C and GH_B are not normal PWM waves, but a sudden drop of more than 30 v. the power supply voltage I use is 12 v.

Can you post oscilloscope traces for GH_C and GH_B?
Can you also post a photo of your setup? Maybe you have some noise/grounding issues.