TrapTraj mode is not doing anything

Hey folks,

today i wanted to try out the TrapTraj-Mode, but nothing is happing. Neither when changing input_pos nor when calling move_incremental() function. See my current settings here:


Is control_mode = PositionControl correct?

Thanks for your help!!

Works great on devel.

Control mode position
input mode trajectory
must be fully calibrated and running in closed loop

Motor is fully calibrated, current_state = ClosedLoopControl but when i set input_pos nothing happens, the controller.pos_setpoint does not move at all…

Strangely, now it works… i don’t have a clue what is different now, but it works, thanks!

I’m facing a strange issue when in Trajectory control mode, the Input_Pos doesn’t actually lead to a change in the setpoint and the motor doesn’t move.

I’ve checked that there are no errors, the current state is closed loop, its in the Position Control mode. The issue is intermittent but very much persistent.

Is there a bug in the 0.5.4 firmware version??

Yes. Please upgrade to 0.5.5.

Thank you for the update, I didn’t realize a new version had been released. Will upgrade to this.

Hi , it appears that the firmware is unreleased? I’m not able to find a .HEX file for this? Can you provide a link on this or let me know when this will be officially released?

Oh uhh I can’t check too closely right at the moment, but the official way to update is:

pip install --upgrade odrive, then power on your ODrive and use odrivetool dfu. The up to date odrivetool is quite reliable for flashing

odrivetool dfu, doesn’t work. Its unable to find the Odrive for some reason. It sends a “No backend available error”

I tried setting it to the DFU mode via dip switches and powered on, still same issue.
Tried connecting GPIO 6 to GND, powered on, still same issue.

That’s when I wanted to try the manual approach but no .hex files to be found

And you are on odrivetool 0.6.3?

Yes that’s correct, the latest one

The .elf filles are available here ODrive Releases

Yeah but I need the .hex files. Hasn’t the 0.5.5 release been made official. I thought I could find it here but its not been added to Github.

We don’t provide .hex files anymore, sorry. ODrivetool 0.6.3 and the STM32CubeProgrammer can both take .elfs. Is there a specific reason you need the .hex files?

I made the release official on Github a few days ago :slight_smile: