What am I doing wrong?

Hi there,

it’s me again, I reinstalled ubuntu and started over again but I still have the same problem, it’s probably very simple but I don’t see it, when I run the commands from the getting started document, everything is fine, the odrivetools is installed succesfully but when I enter ‘odrivetool’, it says ‘odrivetool: command not found’

Does anyone know what I’m doing wrong?

greetings Stijn

Hi Stijn, try; sudo odrivetool --verbose

Then at the least you should have some more information, if an ODrive connection and a motor is available.


Hi Stijn, when you use; sudo odrivetool --verbose

Do you get this???

user@3820-user:~$ sudo odrivetool --verbose
[sudo] password for user:
ODrive control utility v0.4.1
Waiting for ODrive…
USB discover loop
ConfigurationValue 1
InterfaceNumber 0,0
EndpointAddress 130
InterfaceNumber 1,0
EndpointAddress 1
EndpointAddress 129
InterfaceNumber 2,0
EndpointAddress 3
EndpointAddress 131

Kernel Driver was not attached
EndpointAddress for writing 3
EndpointAddress for reading 131
Connecting to device on USB device bus 2 device 5
Please connect your ODrive.
You can also type help() or quit().

if so this is the problem!!!

Kernel Driver was not attached

and had No luck loading it or building it in to the kernel.

Its a mystery :thinking:

Regards Jerry.

I can test this in 3 hours
greetings stijn

I’m getting nothing

greetings Stijn

Hi Stijn, might be a daft suggestion, I don’t know how familiar you are with Ubuntu, but are you in the correct directory? Type in “ls”. Also linux files need to be tagged as executable to run, so that might be it.


I have just a basic knowledge but I think I’m in the correct directory, I will check when I’m home, can you maybe write the exact things I need to enter in order?

thx for the reply

cheers Stijn

I don’t have access to Ubuntu at the moment but type “ls” into the terminal, you should see odrivetool there if you’re in the correct directory, if not type "cd " then the folder path where it is.
If you can see it, first type “sudo ./odrivetool”.
If that doesn’t work, type “chmod -x odrivetool” and try again.

thanks, I will contact you when I’m at home

I think the issue is that you are missing the local directory reference… You need to put ./ in front of your command, like Neil says above. “sudo ./odrivetool”.


Thanks for all the replies, I will be home in 5 hours, then I can test it :slight_smile:

cheers Stijn

Hi Stijn, by default odrivetool is here


If you like you can use " Install locate to find any file, including odrivetool"

sudo apt-get install locate

And before you use “locate” “Run” sudo updatedb

After you have applied the above; open terminal, type “locate” followed by the file you are looking for, and in this case odrivetool :grinning:

Regards Jerry.

What now boys?


Try this:
cd /home/stijn/.local/bin

The odrive tool is not located in your home directory, it was put in that subdirectory called .local so you need to change into that directory and then run it from there. When you used the command cd to change directory you gave it the full name to the file that you want to run… the file odrivetool is a file, not a directory, which is why it gave you the error “Not a directory”. What you need to do is change directory (cd) to the directory that it’s located in which is /home/stijn/.local/bin and then from there run it using ./odrivetool. The “./” in front is important because that means “run this file from the current directory”.


This worked, thanks a lot!