0.5.3. firmware with 0.5.2. backup-config

Hello everyone,

I’m facing some trouble since this morning, after flashing the new firmware 0.5.3. on my 56v v3.6 odrive.

My motors (two hub motors with hall sensors) were properly tuned for 2 weeks and everything worked nicely, until this morning when I tried to configure the endstops of my motors, following the “Endstops and Homing” procedure. When I got to the line odrv0.config.gpio1_mode = GPIO_MODE_DIGITAL, I got an AttributeError : attribute gpio1_mode not found. Some research led me to this post, which advised I should upgrade odrive, and use odrivetool dfu to update, in order to configure my gpioX_modes. Everything went without problem.

But when I tried to make my motors spin as I did before just after the upgrade, nothing happened, and till now I can’t find a solution make them spin. I used restore-config to make sure I’m using the exact same configuration but it doesn’t seem to help.

Any idea what could have happened ? Is there some kind of incompatibility between a 0.5.2. configuration and a 0.5.3. firmware ?

Thanks a lot for any help,


Yeah, use erase_configuration() and do it over manually. There’a always incompatibilities