AMS AS5048A SPI doesn't work

Hello my friends. Please can somebody help me? I have just received my absolute encoder AMS AS5048A, and I can’t make it work. I tested it with the Arduino library at it worked very well.

In the Odrive, after doing the configuration:

odrv0.axis0.motor.config.pole_pairs = 15
odrv0.axis0.motor.config.resistance_calib_max_voltage = 4
odrv0.axis0.motor.config.requested_current_range = 25
odrv0.axis0.motor.config.current_control_bandwidth = 100
odrv0.axis0.motor.config.torque_constant = 8.27 / 16 #hoverboard KV

odrv0.axis0.encoder.config.abs_spi_cs_gpio_pin = 4 #or
odrv0.axis0.encoder.config.mode = ENCODER_MODE_SPI_ABS_AMS
odrv0.axis0.encoder.config.cpr = 214 # or 212 for AMT232A and AMT233A
odrv0.axis0.encoder.config.bandwidth = 1000

odrv0.axis0.controller.config.pos_gain = 1
odrv0.axis0.controller.config.vel_gain = 0.02 * odrv0.axis0.motor.config.torque_constant * odrv0.axis0.encoder.config.cpr
odrv0.axis0.controller.config.vel_integrator_gain = 0.1 * odrv0.axis0.motor.config.torque_constant * odrv0.axis0.encoder.config.cpr
odrv0.axis0.controller.config.vel_limit = 10
odrv0.axis0.controller.config.control_mode = CONTROL_MODE_VELOCITY_CONTROL

I tried to do the motor calibration

odrv0.axis0.requested_state = AXIS_STATE_MOTOR_CALIBRATION

I didn’t got the beep, but it shows the values and zero erros,

After that I tried to
odrv0.axis0.requested_state = AXIS_STATE_ENCODER_OFFSET_CALIBRATION

Here is the problem, nothing happens and the the error appeared

I’m using the odrive V3.6-56V and the firmware v0.5.1.post0

does any one know what I can do to solve the problem?

Do you have any ferrite chokes?

Also, try reducing your supply voltage.

If you have an oscilloscope, see if you can see the same SPI glitches that I get with these sensors.