Another Hoverboard wheel calibration issue

Hello. Noob here. I’m trying desperately to get the hoverboard wheels to work.

I’ve got a new 3.5V 48 volts ODrive, trying to get it to work with standard hoverboard wheels (rated 260 pounds)at 36 volts. I’m using the battery which is charged to capacity (showing 39 v). The wheel is identical to the instructions (30 magnets) so i copied and pasted the code line by line in that demo.

I have issue when I try to calibrate. The motor moves a slight bit and no beeping is heard. (See my results below) I’ve triple checked the wiring (although i do have a left over white wire), tried with and without 22nf caps on the hall effect encoders.

To be honest, I’m going to be running them with PWM and if I can’t figure this out would be quite happy to run them in sensor less mode, if you can do that with hoverboard motors?!

But in the mean time…any one have pointers what to try next for trouble shooting the calibration? (there are only 30 support questions for the hoverboard motors)

EDIT: I’m pretty sure after hours of tinkering that this left over white wire is somehow connected to the encoder (as on the original boards inside the hoverboard,…see new added pic) The white wire in the group of encoder wires. Any idea what this extra wire might be for or where to connect it to the odrive?



Edit #2: It seems the extra white wire acts as a temp sensor or possibly a speedometer signal. I found a few other posts that shows this “6th” wire and that was the only description I could find. Its unlikely this is my issue now. I could not imagine the encoders not working because of this wire not being connected somewhere.

Back to the drawing board.

Hello,

I have run into the same issue, and tried almost everything on the forums. Did you figure your problem out ?