Array Index Out of Range on DFU Update Windows


#1

Forgive any noobiness that follows:
Machine: Win10/Ubuntu 16.04 dualboot
Odrive: 3.5-48v
Firmware: v0.4.1-dev (unchanged from when I received it)
Python: Standalone, 3.6.2

My Goal: I’m looking to compile and flash the devel branch firmware so I can use my odrive with a couple hoverboard motors.

I’m currently making a go of this on the windows side of my machine and running into errors while trying to change the firmware on my odrive. If I run odrivetool dfu with the odrive’s physical switch on DFU mode I end up with this:

( I did the zadig utility to set the driver for STM32 BOOTLOADER to libusb-32)

Any thoughts on what might be going wrong?

Thanks in advance!


#2

Hi, we have had a bunch of issues with DFU mode, and I think yours is actually a new variation. Can you please add these details to the github issue?

It may take us a while to really nail this down, I’d be happy to send you an ST-Link in the mean-time so you can flash your board. Please DM me your shipping address.

Cheers


#3

I ordered a couple of odrive boards a few weeks back which I intend to use with brushless hub motors and have ended up with the exact same error as alonks above. I have ordered an stlink to see if that will work around the issue.


#4

We found a different tool that can flash the ODrive in DFU mode. It’s not as sleek and automated as the dfu command in odrivetool, but hopefully it can help if you are getting errors.

Instructions here