Axis error 0x5 always

So the Odrive gives the axis error 0x5 all the time, even right after rebooting. I looked at the error codes and does this mean there is something wrong with the break resistor? I already tried setting its resistance to 0 to disable it but it doesn’t help. If it matters, it was after a firmware update that this started.

I think axis error 0x5 would be ERROR_DC_BUS_OVER_VOLTAGE with ERROR_INVALID_STATE.


I’m guessing thats why you ask about the break resistor. If so, what supply voltage are you using and what voltage version of odrive?

It is 0x5. The version is 3.5 and 48v, I’m running it with 36v. Is it possible during a firmware update the maximum bus voltage was changed to be for the 24v version?

Try connecting with odrivetool, then using

odrv0.config.dc_bus_undervoltage_trip_level = <something reasonable>
odrv0.config.dc_bus_overvoltage_trip_level = <something reasonable>

1 Like

YES! It worked thanks for the help.

@Voids_Warranties I’m curious to know what were these parameters were set to and what did you change them to, to get it to work?

Undervoltage was set to 8v and I left it at that
Overvoltage was set to 26v I believe, I changed it to 52v the saved configuration and rebooted. I stopped getting the overvoltage error but I haven’t actually tested it yet

1 Like