Brake resistor got hot while not moving

Hi, I recently got an ODrive v3.6 (24V version) and upgraded the firmware to v0.5.1.
I connected both motors with both encoders, the provided brake resistor and used a bench power supply set to 15V.
I followed the guide and calibrated the motors, the encoders and everything is working nominally. While the motors are engaged in closed loop mode the total power drawn from the power supply is around 1.5W

I did all the testing using odrivetool v0.5.1.post0 on a RPi 3B+. At the end, with both motors engaged, i ran a dump_errors(odrv0) and no errors were given. Then, after running odrv0.save_configuration(), motor0 disengaged, while motor1 did not.
This is quite strange, but not an issue to me, even though I’d like to understand if that’s normal.

After this, I’ve quit odrivetool by typing exit() on the python shell, I ran odrivetool backup-config and shut down the RPi while leaving the odrive powered, I came back in 10 minutes and I noticed on the bench power supply that the power consumption was over 10W, so I wondered where that energy was going and started to touch the heatsinks on the board and the motors. Everything cool, but when I touched the brake resistor I got burned, I think it was well over 100°C, the board must have connected the resistor to the main power rail, since the motors were not moving at all in the last 10 minutes.

This is the config

I’ve been able to reproduce this problem just twice, but if I’ll manage to do it again I will post an update here with a detailed procedure.

Thanks in advance to anyone who can help

Don’t save configuration while the axes are running, it will do bad things ™. This is fixed in the upcoming firmware.


Oh okay perfect. So I don’t have to worry, my board shouldn’t be broken then. Thanks for the reply!

What should I do if i want to save the configuration? Put axes into IDLE?

Yes, put the axes in IDLE.