Building toolchain for modifying firmware on Odrive - Windows 10

Hi There,

I have an Odrive v3.6, and have till now managed to control it via an Arduino / STM32 UART @115200, and also via Odrivetool and also ODrive_gui by PJohnson

I also have the ST-LINK v2 and have managed to load latest firmware 0.5.1 from the repo as well as go back to previous V4.1.2

My objective is to attempt to write UART commands to the ODrive at speeds well above 115k2 - perhaps 921600 from my STM32 dev boards ( I know Arduino Megas do not speak well above 250K )

To cut my long story short, I need UPDATED helpful documentation on how to set up a toolchain for Windows 10 machine. I have attempted to follow the instructions in the Developer guide to set up first VS, then I attempted Eclipse.
None worked. Reasons - it is my opinion that the instructions there are outdated, and I banged my head on Google’s wall so much that it hurts. Searching here in this community I found a couple of requests for help, which I have read.

Could someone release a step by step , single page/document guide on how to setup a working toolchain on a fresh WIN10 machine ?
I see that some users in this discourse have promised to make a complete guide.

I really would not like to go the VM/ubuntu route.

EDIT: I went ahead and installed 18.04 on a VM, and followed the instructions, supposedly to the letter.
Darn “make” - still fails for me.

Thanks a million !

If you’re going that fast, I’d recommend CAN over UART, since there are fewer overheads (binary message format, not ASCII), built-in CRC, and CAN is able to run at 1Mbps. Future ODrive versions may include CAN-FD which can go higher still.

Not something I personally can do, sorry. Not unless the first step is “Erase disk” :wink:
Haven’t been a ‘Windows User’ for… 20 years.

What is the error? Shouldn’t you be running tup rather than make?
Did you copy tup.config.default to tup.config and configure the tup.config file?

Hi Tom ! Thanks for taking the time to reply !

What is the error? Shouldn’t you be running tup rather than make ? <<

Developer guide :slight_smile:
image

Can you let me know what to do to run tup in the firmware folder ?

Did you copy tup.config.default to tup.config and configure the tup.config file?

Yes, and it looks like this:

Therefore, the error I’m getting when i run “make” in the firmware folder is:

It would be great if I can get some assistance to be able to make or tup some firmware !
Cheers !

I am running a successfully installed Ubuntu 18.04.5 LTS, on VM VirtualBox,
and followed the Developer guide and the Getting Started pages to install the tools, including the prerequisites that the error code in the last image is reporting

Have you tried following the link in those error messages? :slight_smile:

It seems you were following an older version of the developer guide. The error message itself points you to the latest version of the developer guide :stuck_out_tongue:

Sounds like you need to do apt-get install python3-jinja2 amongst other things.

Hi Tom, How can I send you some Beer tokens ?

I wanted to still compile Odrive 0.4, so I did not follow the hidden github developer guide for 0.5.1
So I followed the one linked from the main blog site.

Therefore, now, I followed your link to the github developer guide and re-installed everything in the Linux (ubuntu <20.04 )

Tom, this is the result. and I am sooooooo sooooooo happy :slight_smile:
THANKYOU !!

2 Likes