Cannot connect in Run Mode

I have finally managed to get round to testing my Odrive board and disappoint to find I only seemed to connect to it once.

It will now no longer connect with the USB in run mode.

It will, however, connect in DFU mode and a tried updating the firmware with the STM32CubeProgrammer to the latest version V0.5.2 but this did not fix the problem.

Hi @Rollmop Do you get any errors when you try to connect, or can you simply not see the device in Device Manager?

When the dip switch is in run mode nothing appears in Device Manager.

If I have it set to DFU mode I get ‘STM32 BOOTLOADER’ appear in Universal Serial Bus Devices

good day sir, any update about this problem ?

You could try to roll back to 0.5.1, or forward to 0.5.3 (from the development branch). Is this ODrive purchased from

thank you very much!!!

Sorry for the delay in replying, Yes all sorted with some help from the fella’s at odrive

What did you do to get this fixed? I am having the same issue. I also tried to update the firmware but I can’t get it to update for some reason