Cannot connect using odrivetool

Just purchased 2 new 56v odrives v3.6s. Connected them to a 48v 25a PSU (confirmed voltage with multimeter).

Tried on 2 computers running Windows 10. Both show up in device manager just fine.

Tried both odrive boards.

Tried multiple usb cables.

Installed Zadig and tried both libusb and WinUSB drivers.

Tried - Run odrivetools with the --verbose option

Any help would be greatly appreciated! I need to get this working today for my company.

Also admins - the search feature is broken on the forums.

Reflashed both control boards and I can now connect to them.

It’s really strange that both boards came with bad firmware.


It is sometimes (rarely) possible to erase the flash on the STM32 with high inrush current, it’s a really weird one. My boards went through a phase where I had to gradually increase the voltage instead of hitting them with 50V otherwise they would lose their firmware - but now they seem to be fine. :confused:

1 Like

Hmm, I wonder if 0.5.1 (which is still shipping on new boards) isn’t connecting properly with the newest odrivetool?