Can't find Odrive device on both windows and ubuntu

When I first connect ODrive3.5 to windows, it works well.And when I type “odrivetool”, it can be detected. I type “odrv0.vbus_voltage”, it’s output is something like 22.666565165. All the things works well till now.
Then I want to re-flash the firmware ,update to the latest version via " odrivetool dfu" and follow the docs to install driver using Zadig. But at last comes the error: The device has no langid .

I want to try again. I close the console, turn off power and restart everything .But this time the Odrive device doesn’t appear in both windows device manager and Zadig.

Then I turn to the ubuntu18.04:
if type “sudo odrivetool -v”,it shows like follows(the “USB discover loop” never stop):

if type “lsusb”,shows like follows:(seems no odrive device)

if type “dmesg”,shows like follows:(the SerialNumber seems like belong to ODrive,but it says “USB disconnect, device number 7”)

And my 91-odrive.rules is:

any advice to this situation?
Thanks!

Hi, I am also having similar issues. My PC is also now no longer able to detect the ODrive after I tried to do some firmware updates. It doesn’t show up in device manager and odrivetool no longer locates the odrv0. However, my PC can pick up the STM32 Bootloader if i’m in the dfu dipswitch mode, but nothing otherwise. Is there maybe a way to hard reload the firmware in with the ST-link or any other means?
Thanks!

Hi, happy to share with you.
1.I download the corresponding .hex file(https://github.com/madcowswe/ODrive/releases)
2.flick the DIP switch on the board from “RUN” to “DFU”, power the board.
3.now use “odrivetool dfu yourpath/firmware.hex” .Then flash successfully(but still can’t be detected).
4. power off and filck the DIP switch back to “RUN”.
5.power on again.Now, the device should be detected.

I tried this method on both windows and ubuntu18, all works well.
You can have a try! Good Luck!

1 Like

Hi,

Thanks so much for your help! I tried it and it erased everything successfully, but then I got this error upon trying to Flash :confused: From the third line, it sounds like I actually had the firmware fine but I was too eager to try this method so still went ahead >< Maybe just put myself in more trouble :s haha. But hopefully this error can shed light on what the issue with my odrive is?