Can't setup sensorless

Can someone direct me to a resource that will guide me on how to setup sensorless mode on the ODrive? I’m using the most recent hardware (3.6) and I’m on firmware v0.5.4. Note, sometimes calibration doesn’t want to work either. I am using a flipsky 6374 battle hardened BLDC motor (190kv).

I tried following the docs on this page, but it did not seem to work. Here were my values:

odrv0.axis0.controller.config.vel_gain = 0.01
odrv0.axis0.controller.config.vel_integrator_gain = 0.05
odrv0.axis0.controller.config.control_mode = CONTROL_MODE_VELOCITY_CONTROL
odrv0.axis0.controller.config.vel_limit = odrv0.axis0.config.sensorless_ramp.vel / (2*3.14 * 7)
odrv0.axis0.motor.config.current_lim = 2 * odrv0.axis0.config.sensorless_ramp.current
odrv0.axis0.sensorless_estimator.config.pm_flux_linkage = 5.51328895422 / (7 * 190)
odrv0.axis0.config.enable_sensorless_mode = True

Then I ran:
odrv0.axis0.controller.input_vel = 1
I tried with some other values as the input velocity, but none seemed to work. Any ideas? What am I doing wrong?

1 Like