CPR Pole Pair Mismatch

I am attempting to configure a motor with a 1000 line encoder, 3.3 ohm resistance. I hav it set to gimbal motor, 12 amp (volt) limit, 12 volt resistance calibration limit. The cpr setting is good, if I manually turn the motor 50 revs the encoder, pos estimate shows 50. I have tried every pole pair number from 2 to 10 and all have the same error. the motor turns 4 revs and errors. Increased the calibration distance to 200 and it turns 15 revs and faults. I have tried everything that I could find in the docs, discourse and discord. files. I have run out of ideas. Does anyone else out there have anything? Thanks


I did finally get the mismatch cleared by setting the pole pairs to 2 and tweaking some of the other motor settings. Now it has motor unknown torque and controller spinout errors when I do the full calibration seq. The motor turns 4 revs in bot directions and stops with the errors listed above. It does the same if I run the encoder offset routine. The motor is high resistance, 3.3 ohms. The motor settings are:

Motor type 2,current lim 11(volts),current lim margin 8, calibration current 11, phase inductance .001444513~, phase resistance 1.22106~, pole pairs 2, requested current range range 60, resistance calib max voltage 10. torque constant 1. I have tried torque constants from .1 to 1 with no different results. Ideas?