Dead Board V3.6


I have an Odrive V3.6 at 56 Volts.

When first testing, I was able to connect to the ODrive with the odrivetool in Ubuntu. I was able to adjust the configuration for my motor and encoder setup and the limits. ( I am running it at 30V)

Upon running:

odrv0.axis0.requested_state = AXIS_STATE_CLOSED_LOOP_CONTROL

nothing moved and the error was: ERROR_DRV_FAULT.

I tried the same with M1 and this beeped and moved the motor as it should. I then preceded to increase the calibration current limits from 2A back to 10A for M0 and increased the max RPM back to default as these were the only values I changed for M0.

I saved the configuration and tried to reboot and the Odrive was not detected. I have tried on Ubuntu 16 and 18 and also on Windows 10 with anaconda and python.

I tried to update firmware but when running: odrivetool dfu, the ODrive is never found. I have disconnected everything from the board at this point but its not detected by the odrivetool in any OS.

I think there is problem with my board.

Has anyone experienced this?



Hi eisa,

Do you have a green LED on the board when you power it?


Yes I do have the green LED when the board is powered on.

I have actually obtained a new board from my university and this one is functioning perfectly with pretty much exactly the same settings, so I think it’s a hardware error on the first board.

I also picked up a USB programmer so I might try to re-flash the firmware?



Yes, if you have the STLink, you can try re-flashing that way, it’s much more reliable.


I tried to flash with the STLink. It returned an error saying it was unable to connect to the target.

I’m pretty sure this board is defective. I have not been able to get it working at all and the other Odrive (the same voltage and version) I am using seems to be OK.

Do you have any other suggestions? Can I get a replacement board?


Hmm… curious. Please email with the problem and link this thread.