DFU Update and Setup issues

Hi, I am start using the odrive but I have issues to get it running.

First I startetd to test the odrive with a TURNIGY motor but I didn’t get it to run. Then I tried to update the odrive but now it is lost. I found the " Upgrading firmware with a different DFU tool" but if I come to the point to find out the serial number the tool do not show anthing:

MBP Downloads % dfu-util --list
dfu-util 0.9

Copyright 2005-2009 Weston Schmidt, Harald Welte and OpenMoko Inc.
Copyright 2010-2016 Tormod Volden and Stefan Schmidt
This program is Free Software and has ABSOLUTELY NO WARRANTY
Please report bugs to http://sourceforge.net/p/dfu-util/tickets/

The odrive ist powered up and connected with USB, in the same way I did the first steps and there the board was availiable.

So this is now my problem. To get the motor running is now the secound step …

Best regards

Ok, I could reload the firmware with the alternative tool AND switch to DFU on the board. The guide is not so clear in this point for me.

So this issue is soveld.
Now I testet the motor again. The M0 is in my oppion broken. On M1 it works. The calibration works (beep and move forward and backward), but with the loop command the motor makes a hard move and then I can move it freely.
I will check the params again but I think M0 is not working corretly.

Ok now M0 is also working. I erased the config vor M0, reboot, new config and now it works.
Solved :slight_smile:

1 Like

Cool, glad you got it working :smiley:

As addition explanation. I tried to connect with my Windows 10 too, but it woun´t work. So I went back to my Mac and erased, reboot and reconfig. So now I know how it works on my mac :slight_smile: