Disconnecting over USB

Hello, my Odrive 56V is conected via USB. Only one motor(1) is connected and an AS5074P. All works well as far as I can tell. Now if I go into closed loop the Odrive disappears and reappears all the time. I can still send commands so its not that big of an issue. But I was wondering what the issue could be?
Problem comes if load is applied in closed loop. If no load or idle the problem goes away.

odrv0.axis1.requested_state = AXIS_STATE_CLOSED_LOOP_CONTROL
Oh no odrv0 disappeared
**Reconnected …
… “”“repeats about every 2sec”""
odrv0.axis1.requested_state = AXIS_STATE_IDLE

Okay update: after further testing the Odrive disappeared completely and did not reapear.

Fix: I changed from M1 MacBook pro with OSX to 2015 Macbook running Ubuntu and that “solved” the problem.

1 Like

I also have the same problem of USB disconnect when there is load and the motor goes into closed loop. We have 3 boards of 56v connected.
The platform is RaspberryPi. I tried in another ubuntu laptop as well and the problem is the same. We already have magnetic beads in the phase wire.

Can I put any kind of optical isolators on the USB?
Is there any recommendations here. I know it is because of high surge current and common ground problems. The encoder also has the magnetic beads

We sell USB isolators in the shop. Highly recommended