Encoder is not listed under axis0

I’m trying to run a hoverboard motor with odrive pro.
Link of Motor : Long Life High Efficiency Electromagnetic Brushless Skateboard Hub Motor 8352 For Outdoor Sport - Buy Brushless Motor,Hub Motor,Skateboard Motor Product on Alibaba.com

I’m trying to run this with GUI on the google chrome browser with gui_flutter link.
I want to configure the hall effect sensor on axis0 but there is no encoder listed under axis0.
Please find attached a screenshot for reference.
I’ve tried with Anaconda terminal but the same issue I’m facing there.
Please find attached a screenshot for the same.

I’ve followed all steps from starting.
Please provide a solution asap.
Thank you.

Hello Akhil,

It seems I run into the same problem as you. I looked into the structure with my command window. They changed the structure a bit. They divided the encoders. You can configure them with odrv0.hall_encoder0.config… instead of odrv0.axis0.encoder…

Yes, we’ve changed the Pro structure quite a bit. Please check the Beta docs for more info Getting Started — ODrive Pro Documentation beta documentation