Encoder polarity calibration failed with encoder error

I am stumped.

I am using the script developed by Lukas Kaul for installing parameters for hoverboards (ChIMP/tools at master · CharlestonRobotics/ChIMP · GitHub). This is the latest iteration of his hoverboard script on this site.

I received the dreaded ENCODER_ERROR_ILLEGAL_HALL_STATE error on axis 0, but not 1, which rendered “Succesfully calibrated axis1!”

Motor check. I swapped motor and hall connections to connect the old axis0 hoverboard motor and sensors to M1 on the odrive, and reran the install script. “Succesfully calibrated axis1!”

so I am assuming that both motors are ok and wired correctly

So I tried capacitors from each hall sensor to ground

I used protoboard and rigged up the recommended 22nf, then 47nf, caps. No joy. Same result (except both drives show ENCODER_ERROR_ILLEGAL_HALL_STATE with the 47nf caps.)

I am waiting on Amazon to deliver some toroids but that’s my last shot at it

Any ideas offered will be great appreciated. A one legged robot is no fun. Thanks

1 Like

Toroids rule!

1 Like