Error after calibration


#1

Hi, I have just got my new Odrive and I am trying to control the position of a motor. I have tried to do as the getting started documents says. But then, when I did the calibration I have got this error:

hex(odrv0.axis0.error)
‘0x41’

When I did calibration, there is beep sound and the motor does rotate, but only to one direction. Before I did the calibration I have check that the error was 0x0. Like this:

hex(odrv0.axis0.error)
‘0x0’

My setup was like this:

odrv0.axis0.motor.config.pole_pairs=7
odrv0.axis0.motor.config.motor_type=MOTOR_TYPE_HIGH_CURRENT
odrv0.config.brake_resistance=2
odrv0.axis0.encoder.config.cpr=8196

Although I’m not really sure about the number of pole pairs.


#2

What encoder do you have? 8196 is not a common CPR value (8192 is).


#3

I use AMT102-V as encoder, and you are right I have got the CPR wrong. But Still after I have changed the CPR into 8192, I get the same error.


#4

Strangely enough, after I have changed my pole_pairs into 0 the calibration works, but then when I do
odrv0.axis0.requested_state = AXIS_STATE_CLOSED_LOOP_CONTROL
the motor does try to fight me if i turned it by hand. But when I set new position, nothing happens and there is no error when i checked

odrv0.axis0.controller.pos_setpoint = 10000

In [45]: odrv0.axis0.error
Out[45]: 0


#5

What motor do you have? You should set pole_pairs to the correct value, not 0.

Can you reboot the ODrive, then run the calibration sequence of states that you wish to do. Between each step, can you check the hex(axis.error)? As soon as you have an error, check the troubleshooting guide on how to decode them. For example, you may need to query the motor or encoder error.


#6

I have got alien power system aps6355s, and it has hall effect sensors. I have already tried to do speed control just like in the documentation bellow:

I have tried using a variable power supply before and it works. But then when I changed into another power supply the motor won’t move, even on calibration. I suspected that the power supply didn’t supply enough current to Odrive and the motor because it has current limiter of 3A. So, I would like to know how many amps do I need for the power suply?


#7

I have a similar motor, Tenshock 812, I run it off of a 5a 24V power supply, but I have a large capacitor (5F 30V) in parallel with the motor. This helps the motor start (which generally requires extra amps) and helps overcome any other unexpected power dips.

The 5a powersupply is only enough for rudimentary testing. To actually use the motor I have a 100a powersupply, but batteries would be better.