Error installing Odrive on Raspberry Pi 3 B+

#1

After giving up on trying to connect the odrive on windows 10 I tried installing the odrive tool on a raspberry pi 3 B+. Whereupon I got the following error:

pi@raspberrypi:~ $ pip install odrive
Collecting odrive
  Downloading https://files.pythonhosted.org/packages/43/42/fcc8a36932f82d0dd30236ba9956d8410932e890dbeb959fe4b66bcf1cef/odrive-0.4.8.tar.gz (43kB)
    100% |████████████████████████████████| 51kB 510kB/s 
    Complete output from command python setup.py egg_info:
    Traceback (most recent call last):
      File "<string>", line 1, in <module>
      File "/tmp/pip-build-5zWX3_/odrive/setup.py", line 94, in <module>
        import odrive.utils
      File "odrive/utils.py", line 9, in <module>
        from fibre.utils import Event
      File "fibre/__init__.py", line 2, in <module>
        from .discovery import find_any, find_all
      File "fibre/discovery.py", line 10, in <module>
        import fibre.protocol
      File "fibre/protocol.py", line 18, in <module>
        from monotonic import monotonic
    ImportError: No module named monotonic
    
    ----------------------------------------
Command "python setup.py egg_info" failed with error code 1 in /tmp/pip-build-5zWX3_/odrive/

Could anyone help point me toward a solution?

0 Likes

#2

Thanks for reporting that bug, we will try to fix it.
In the meantime, run this command first:

pip install monotonic

then try to install ODrive again.

0 Likes

#3

Thanks! Worked great.

Would you also see if you could give me the magic words for this trouble when you get the opportunity?

0 Likes