Firmware build error


#1

When I try to make the code I get the following error. I am on Windows 10 x64.
Can anybody help about it?

D:\ODrive\direct\ODriveFirmware-master>make
The system cannot find the path specified.
mkdir -p build
Middlewares/Third_Party/FreeRTOS/Source/queue.c:2351:2: fatal error: opening dependency file .dep/queue.o.d: No such file or directory
  } /*lint !e818 xQueue could not be pointer to const because it is a typedef. */
  ^
compilation terminated.
make: *** [build/queue.o] Error 1

#2

I have seen this before. I think you can just try make clean.
If that doesn’t work, try deleting the build folder.
(Edit: ignore what I said before about GCC version, that was a different error)


#3

I tried both but they didn’t work. I think the best is to switch to Linux.


#4

Are you using the git bash (as was recommended in the instructions), or some other command prompt?


#5

I actually tried to use readily installed SystemWorkbench with some minor tuning. After then I tried on normal command prompt. I’ll try later git bash. Let you know the result.