Flashing odrive 3.6 bd

I am trying to flash a ODrv36-56V. Using Odrivetool dfu. The first time it started and just hung. So I tried again and again. Moved switch from run to dfu and tried. Get this message:
C:\temp\ODrive-master\tools>odrivetool dfu
[WinError 2] The system cannot find the file specified
ODrive control utility v0.0.0.dev
Waiting for ODrive…
Found ODrive 20553882304E (v3.6-56V) with firmware [unknown version] in DFU mode

Checking online for newest firmware… found v0.4.11
Downloading firmware v0.4.11…
The configuration cannot be backed up because the device is already in DFU mode.
The configuration may be lost after updating. Do you want to continue anyway? [
Y/n] y
Erasing… done
Flashing… (sector 0/6)

RuntimeError Traceback (most recent call last)
C:\temp\ODrive-master\tools\odrivetool in
140 print_version()
141 import odrive.dfu
–> 142 odrive.dfu.launch_dfu(args, logger, app_shutdown_token)
144 elif args.command == ‘liveplotter’:

C:\temp\ODrive-master\tools\odrive\dfu.py in launch_dfu(args, logger, cancellati
452 firmware = FirmwareFromFile(args.file) if args.file else None
–> 454 update_device(device, firmware, logger, cancellation_token)

C:\temp\ODrive-master\tools\odrive\dfu.py in update_device(device, firmware, log
ger, cancellation_token)
380 for i, (sector, data) in enumerate(touched_sectors):
381 print(“Flashing… (sector {}/{}) \r”.format(i, len(touched
_sectors)), end=’’, flush=True)
–> 382 dfudev.write_sector(sector, data)
383 print(‘Flashing… done \r’, end=’’, flush=True)
384 finally:

C:\temp\ODrive-master\tools\odrive\dfuse\DfuDevice.py in write_sector(self, sect
or, data)
185 status = self.wait_while_state(DfuState.DFU_DOWNLOAD_BUSY)
186 if status[1] != DfuState.DFU_DOWNLOAD_IDLE:
–> 187 raise RuntimeError(“An error occured. Device Status: {!r
189 def read_sector(self, sector):

RuntimeError: An error occured. Device Status: (0, 2, 0, 0)
any ideas on what I should do next?

1 Like

I have the same problem!

Is that the “device Locked” status? I forget…

Either way, the way to fix DFU problems is to flash with an STLinkV2 with the ODrive in “Run” mode. If that fails, then you can run make unlock to unlock the STM chip first.

I had same problem. If you are using the 2m usb cable that came with the board, try a 1m long cable.
I wrote up my problem in general “problem with bd 3.6 & odrivetool”. The cable may be the issure.

1 Like