Gui corrupt or wont open

I have just got my odrive running and tuned using the python code (which I am new at and find hard and slow to follow, its taken 2 days to get this far!). I have tried downloading the latest gui, but the zip file appears to be corrupt, even though I have downloaded on 2 PC’s. I have downloaded the exe. file which opens the front page and says there is a java script error and will do no more. I have updated java on the PC and still no joy. Suggestions please.

Hi Andy,

What does the error say? Also note that javascript is unrelated to java (terrible naming, I know).

Can you post a screenshot of the error?

Herewith screenshots of trying to open the zip file (a friend gets the same result) and opening the program from the stand alone exe.

Thank you!

Gui Zip|690x449 !

Java script error|690x387

Thanks for posting that! That javascript error is strange - I am unable to replicate it on my Win 10 machine. The zip file is not the source code, it’s the build of the GUI for Mac. I’m not sure why it’s corrupt, but that is a separate problem. I also can’t open it on Windows.

Which version of windows are you running? 32 or 64 bit?

At this point, the best way to get this solved is to run it from source to get more debugging information.

You’ll need nodejs+npm and git bash. You can get nodejs+npm here: Download | Node.js, and git bash for windows here: If either of those ask you to about adding them to PATH, choose “yes”.

After you install both of those, open git bash and clone the ODrive repo like this:

Skip the npm init part, that was a mistake. git clone pulls the source code from the ODrive repo. After that, change into the ODrive/GUI folder with cd. npm i will install all of the dependencies for the GUI - this takes a long time. On my machine, it took a few minutes for anything to show up after running it.

After the dependencies are installed, run npm run electron:serve to start the GUI. There will be a lot of output in the console. This should cause the same error to happen as you had before, but with more debugging information in the console. Once you do that, can you post the error text (or screenshot) of the end of the console output?

Hi Patrick, Im using the 64bit version of Win 10.

Please find attached the files you requested. I hope they make sense!

I did indeed get the gui opening and behaving as before, by freezing on the opening page.

I do have a full txt file of the complete output og the Git program if that is of any use, but there is a lot of it and I cant upload a txt file to this site.

Many thanks!

new error notification|690x387

Thanks for going through the development build process! I think the problem here has to do with python and your system PATH variable. If you open a random terminal (powershell, CMD), can you run python and it launches correctly? I know you have odrivetool up and running, but if it’s through Anaconda, it may not be on the path correctly.

For example, this is the result you should see:

If it complains that it doesn’t exist, you will need to add it to your path. If you are using anaconda, this link shows how to do that:

If you are using regular python, you should be able to re-run the installer and tick the box to add it to your path.

I am using Anaconda, which I have now reloaded and have ticked the load path option in the setup.

The gui now opens to the first page without the error flag coming up. However it wont get past here. Clicking the 'click her for debug output gives the message in the attached screenshot.

Next step please?

I cant import a dash or configuration.

Are there any preconfigured dash setups available to be imported?

Next step please?

I promise that it’s not supposed to be a scavenger hunt! :smile:

Now that python is available on your path, you just need to install the python dependencies as described here: ODrive GUI Beta Release

On start, the tuning dashboard is available after it finds an ODrive. I’m not aware of any other preconfigured dashboard setups - the GUI is still in early beta. Some other users might have some that they’re willing to share.

Thank you Patrick, thats up and running now! Much easier than typing commands straight into python! Ill get used to it and feedback what I find.

Thanks again.

1 Like

I am having this issue

I am having this result

Did you launch the server first?

Yes. I downloaded all the files and run the ‘npm run electron:serve’ and it works. I had to reinstall all the dependincies again, but it will connect. the .exe file still will not connect. Is there a way that I can compile the code into an exe file locally and see if that will work. Not sure it will work in debug mode but the .exe file wont connect.

1 Like