Help encoder polepair mismatch error troubelshooting

Ok gang… I am at my ends wit here. I have odrive v3.6 24V (using Axis0). Attached are the datasheets for the encoder motor and gearbox i am using. I have tried to use it with the encoder sold in the odrive shop and i have having the same error.

I have the motor hooked up, I have tested that both encoders are technically working independently. I can start the FULL_CALIBRATION_SEQUENCE and get a full rotation of the motor. To achieve a full rotation i had to change the scan distance. I have used values that get a full rotation of the motor as well as a full rotation of the gearbox output. I get one rotation from the calibration sequence and it stops, does not return. Dump_errors() gives Encoder_cpr_polepairs_mismatch. I have exhausted my documentation/ google skills and tried every suggestion in the forum.

Attached are the data sheets and my config file. Could someone please give me some insight.

I thought the low CPR count was messing with it based on a forum post but i tried to use a standard 8192 encoder. However I am not sure if I should be using the gearbox or motor output directly.

Can anyone please give me some insight into the process you would do to get this running or maybe just address the error. really anything would help. happy to answer questions when i get back in the morning!

Here is a dropbox foler with datasheets of the motor setup and my config file (remember Axis0)